import Foundation
let pattern = #"(https?://)?(www\.)?(\S+)(\.[^\s\/]+)(/\S*)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
https://www.google.com
http://coreyms.com
https://www.youtube.com/watch?v=sa-TUpSx1JA
https://www.nasa.gov
www.desmos.com
pastebin.com/s8fh3HAs
https://www.regex101.com/
www.translate.google.com/
https://roblox.com/home
chat.openai.com/?model=text-davinci-002-render-sha
https://www.amazon.com/
agar.io/#ffa
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)