import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)?(www\\.)?(\\S+)(\\.[^\\s\\/]+)(\\/\\S*)?";
final String string = "https://www.google.com\n"
+ "http://coreyms.com\n"
+ "https://www.youtube.com/watch?v=sa-TUpSx1JA\n"
+ "https://www.nasa.gov\n"
+ "www.desmos.com\n"
+ "pastebin.com/s8fh3HAs\n"
+ "https://www.regex101.com/\n"
+ "www.translate.google.com/\n"
+ "https://roblox.com/home\n"
+ "chat.openai.com/?model=text-davinci-002-render-sha\n"
+ "https://www.amazon.com/\n"
+ "agar.io/#ffa";
final String subst = "$3$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}