import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\-0-9xX\\/]{12,21}";
final String string = "5/458/x-/x62x4/xxx=179\n"
+ "5/4081x-/xxx4/xx5=186\n"
+ "6272348/9-xxx638/7=153\n"
+ "8/9-44729-xx8-359/7=133\n"
+ "8-7-539/9/x8-513/9-=122";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}