re = /^(help|support|int\.form)\.eset\.com$/mi
str = 'help.eset.com
support.eset.com
int.form.eset.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end