import re
regex = re.compile(r"^(?:[0-9]{1,3}\. ?)?(?:<media(?::[0-9]+)? ?/?><br ?/?>)*(.*)$", flags=re.MULTILINE)
test_str = ("What does the speaker suggest?\n\n"
"91. What does the speaker suggest?\n\n"
"96. <media:12 /><br />Why is the speaker going to Reynold’s Café?\n\n"
"96. <media:12 /><br /><media:13 /><br />Why is the speaker going to Reynold’s Café?")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)