import Foundation
let pattern = #"(?<=:\s)\w+(?:-\w+)*(?: and \w+(?:-\w+)*)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Product: TLD-1433 infusion Therapy
Biological: CG0070|Other: n-dodecyl-B-D-maltoside
Drug: Atezolizumab
Drug: N-803 and BCG|Drug: N-803
Drug: Everolimus and Intravesical Gemcitabine
Drug: Association atezolizumab + BDB001 + RT|Drug: Association atezolizumab + BDB001+ RT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)