using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[class\*=(?:""|')?(.*?)(?:""|')?\]";
string substitution = @".$1";
string input = @"/***********************
***** SHOULD MATCH *****
***********************/
/* No quotes */
[class*=container] {}
/* Single quotes */
[class*='container'] {}
/* Double quotes */
[class*=""container""] {}
/* Multiple classes */
[class*=""container""][class*=""container-large""] {}
/**************************
***** SHOULDN'T MATCH *****
**************************/
/* With = (exactly equal) */
[class=""container""] {}
/* With ^= (begins with) */
[class^=""container""] {}
/* With $= (ends with) */
[class$=""container""] {}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}