import re
regex = re.compile(r"\[class\*=(?:\"|')?(.*?)(?:\"|')?\]")
test_str = ("/***********************\n"
"***** SHOULD MATCH *****\n"
"***********************/\n\n"
"/* No quotes */\n"
"[class*=container] {}\n\n"
"/* Single quotes */\n"
"[class*='container'] {}\n\n"
"/* Double quotes */\n"
"[class*=\"container\"] {}\n\n"
"/* Multiple classes */\n"
"[class*=\"container\"][class*=\"container-large\"] {}\n\n\n\n"
"/**************************\n"
"***** SHOULDN'T MATCH *****\n"
"**************************/\n\n"
"/* With = (exactly equal) */\n"
"[class=\"container\"] {}\n\n"
"/* With ^= (begins with) */\n"
"[class^=\"container\"] {}\n\n"
"/* With $= (ends with) */\n"
"[class$=\"container\"] {}")
subst = ".$1"
result = regex.sub(subst, test_str)
if result:
print(result)