import Foundation
let pattern = #"\[class\*=(?:"|')?(.*?)(?:"|')?\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/***********************
***** SHOULD MATCH *****
***********************/
/* No quotes */
[class*=container] {}
/* Single quotes */
[class*='container'] {}
/* Double quotes */
[class*="container"] {}
/* Multiple classes */
[class*="container"][class*="container-large"] {}
/**************************
***** SHOULDN'T MATCH *****
**************************/
/* With = (exactly equal) */
[class="container"] {}
/* With ^= (begins with) */
[class^="container"] {}
/* With $= (ends with) */
[class$="container"] {}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)