using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\[WIP\])?(\[PIDSS-\d+]) [[:upper:]].{3,}";
string input = @"[PIDSS-12345] Blah blah
[PIDSS-1] Blah blah
[PIDSS-] Blah blah
^(?![A-Z]).+$
[WIP][PIDSS-1] Blah blah
[WIP]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}