Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(\[WIP\])?(\[PIDSS-\d+]) [[:upper:]].{3,}
/
gm
Input 1
1
New
[PIDSS-12345] Blah blah [PIDSS-1] Blah blah [PIDSS-] Blah blah ^(?![A-Z]).+$ [WIP][PIDSS-1] Blah blah [WIP]