package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?from\s(\S+).*`)
var str = `delete from pear.admin where jdjdj
delete from pear.admin_user where blah
delete from ss_pear.admin_user where blah `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}