#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(var.*=)\s+(([\{\[\]][^\{\}\n]*[\n\r]+(\t[^\r\n]*[\r\n]+)*[\}\]])|([^\n\r]*))"
Local $sString = "var testmultiline = {" & @CRLF & _
" fizz = {" & @CRLF & _
" buzz = "moo"" & @CRLF & _
" }" & @CRLF & _
" buzz = {" & @CRLF & _
" buzz = "moo"" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"var testmultiline = {" & @CRLF & _
" fizz = {" & @CRLF & _
" buzz = "moo"" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"var test2 = null" & @CRLF & _
"" & @CRLF & _
"var test3 = { still single line }" & @CRLF & _
"" & @CRLF & _
"var test4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")