const regex = /<a\s.*?\sclass="\s*view\s*"[^>]*>.*?<\/a>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\s.*?\\sclass="\\s*view\\s*"[^>]*>.*?<\\\/a>', 'gm')
const str = `<a title="viwe" class="view" href="link">blablabla</a><a title="viwe" class=" view " href="link">blablabla</a><a title="viwe" class=" view " href="link">blablabla</a>
<a title="viwe" class="noview" href="link">blablabla</a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}