// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a\s.*?\sclass="\s*view\s*"[^>]*>.*?<\/a>"#).unwrap();
let string = "<a title=\"viwe\" class=\"view\" href=\"link\">blablabla</a><a title=\"viwe\" class=\" view \" href=\"link\">blablabla</a><a title=\"viwe\" class=\" view \" href=\"link\">blablabla</a>
<a title=\"viwe\" class=\"noview\" href=\"link\">blablabla</a>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}