re = /(?P<reference_sequence>(NM|NR|XM|XR)_[0-9]{4,12}|ENST[0-9]{1,11})(\.(?P<version>([0-9]?[0-9])))?(:(?P<prefix>c|n)\.(?P<start>-?[1-9][0-9]{0,7})(?P<start_offset>[+-][1-9][0-9]{0,7})?(?P<ref>[ACTG])>(?P<alt>[ACTG]))?/m
str = 'NM_12345.5:c.1999+500C>A
NR_12345.5:c.1999+500C>A
XM_12345.5:c.1999+500C>A
XR_12345.5:c.1999+500C>A
ENST12334455677:c.1999+500C>A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end