import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\B\\d+\\b|\\B\\{\\d+\\..+\\b\\}|dataVolumeGPRS(Up|Down)link:\\B\\d+|xTime:\\{\\B\\d+";
final String string = "{ num:{3025285000} }\n"
+ "{ ipadd:{iPadd:{iPv4add:{111.111.112.223} } } }\n"
+ "{ ipval:{iPadd:{13.100.1.11} } }\n"
+ "{ :{abc:{-} ddf:{-} mainVALUplink:{139161} mainVALDownlink:{6269538} kppacRR:{bbckdo} xTime:{2019-07-22 18:09:55 -03:00 } ppwo:{-} wwe:{-} iiurur:{qCI:{8} eerrr:{-} pppwie:{-} iiwww:{-} oouryru:{-} gg:{104} oosp:{-} pppsss:{-} } } }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}