import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[\\da-z]+|[\\dA-Z]+)$";
final String string = "TY5TF45TF463CHB7437R\n"
+ "ecrx3yt4cx345748bnc7547\n"
+ "745367456475647378563745\n"
+ "hdgfsdgfsdjfgshdgshdgf\n"
+ "DHFGSDHGFSHDGFHSGFHSDFH\n\n\n\n\n"
+ "sshd434gfhdghHSDGFH324234SDFHSG\n"
+ "SDASGDASDhghgshdfsh\n"
+ "dhf hsh-d-f-837_483@^%f#@^#2482\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}