import Foundation
let pattern = #".{2}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"596d396962334a76"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\x$&"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)