#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{8}"
Local $sString = "Restoration Coder: Mr. Vivek Patel 488.90 488.90" & @CRLF & _
"Attn: Mr. Matt Lomano (WO# 24107788)" & @CRLF & _
"0le Asphalt Repairs (Traffic ControltRemoval ofSpoilsfiSawcutting)" & @CRLF & _
"80 W est. Beaver Creek (Richmond Hill)" & @CRLF & _
"Restoration Coder: Mr. Vivek Patel 196.76 196.76" & @CRLF & _
"Attn: Mr. Matt. Lomano (WO# 23407489)" & @CRLF & _
"cfo Sod Repairs" & @CRLF & _
"270 Avro Rd (Maple)" & @CRLF & _
"Restoration Coder: Mr. Vivelc Patel 282.60 28260" & @CRLF & _
"Attn: Mr. Matt Lomano (W03? 23713545)" & @CRLF & _
"cfo Sod Repairs (Removal of Spoilszopsoil/Seeding)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")