$re = '/^\[[^\]]+\]\((?:\s*<?https?.+>?\s*)\)/m';
$str = '[test](https://stackoverflow.com/)
[test](<http://google.com>)
[test](<https://google.com>)
[test]( <http://google.com>)
[test
](
<http://google.com>
)
[test]( < http://google.com >)
Consider the clopen interval [0, 1).
We contrast this with (0, 1](I don\'t know why you wouldn\'t put a space
before the left parentheses...
but why not. Refer to https://google.com)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);