# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(SELECT|DELETE)(?:\s*\/\*.*\*\/\s*?)*\s+FROM*\s+([^\s\/*;]+)?|(?:(?:(CREATE|ALTER|DROP)(?:(?:\s*\/\*.*\*\/\s*?)*\s+OR(?:\s*\/\*.*\*\/\s*?)*\s+(REPLACE))?)(?:\s*\/\*.*\*\/\s*?)*\s+TABLE(?:(?:\s*\/\*.*\*\/\s*?)*\s+IF(?:\s*\/\*.*\*\/\s*?)*\s+EXISTS)?|(UPDATE)|(ALTER)|(INSERT)(?:\s*\/\*.*\*\/\s*?)*\s+(?:INTO?))(?:\s*\/\*.*\*\/\s*?)*\s+([^\s\/*;]+)|(?:(REPLACE)(?:\s*\/\*.*\*\/\s*?)*\s+(?:INTO?))(?:\s*\/\*.*\*\/\s*?)*\s+([^\s\/*;]+)(?:\s*\/\*.*\*\/\s*?)*\s+([^\s\/*;]+)"
test_str = ("DROP TABLE IF EXISTS tbl1; CREATE TABLE tbl1 ...\n"
"CREATE TABLE tbl1 ...\n"
"CREATE OR REPLACE TABLE tbl1 ...\n"
"INSERT /*some comment*/ INTO tbl2 ...\n"
"INSERT /*some comment*/ INTO tbl2 ...\n"
"UPDATE tbl3 SET col1 = ...\n"
"/*some garbage comments*/ UPDATE tbl3 SET col1 = ... \n"
"DELETE from tbl4 ...\n"
"select from select_table insert into table_ttt\n"
"alter table alter_table \n"
"#1 some optional statements like CREATE /*some comments*/ TABLE table_name everything else\n"
"#1 some optional statements like CREATE /*some comments*/ OR REPLACE TABLE table_name everything else\n"
"#2 some optional statements like INSERT /*some comments*/ INTO /*some comments*/ table_name\n"
"#3 some optional statements like UPDATE /*some comments*/ table_name everything else")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.