#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[^:\n]+:).*(\n\1.*)*"
Local $sString = "Subject: this is text not to be matched" & @CRLF & _
"Subject2: this is text to be recognized." & @CRLF & _
"Subject2: This text can be different." & @CRLF & _
"Subject2: ..and this text will be also matched in the first match." & @CRLF & _
"Subject3: This text alone." & @CRLF & _
"this text will not be matched" & @CRLF & _
"Subject2: New start of a new match." & @CRLF & _
"Subject2: continuation of the above line"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")