$re = '/(^[^:\n]+:).*(\n\1.*)*/m';
$str = 'Subject: this is text not to be matched
Subject2: this is text to be recognized.
Subject2: This text can be different.
Subject2: ..and this text will be also matched in the first match.
Subject3: This text alone.
this text will not be matched
Subject2: New start of a new match.
Subject2: continuation of the above line';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);