import re
regex = re.compile(r"(^[^:\n]+:).*(\n\1.*)*", flags=re.MULTILINE)
test_str = ("Subject: this is text not to be matched\n"
"Subject2: this is text to be recognized.\n"
"Subject2: This text can be different.\n"
"Subject2: ..and this text will be also matched in the first match.\n"
"Subject3: This text alone.\n"
"this text will not be matched\n"
"Subject2: New start of a new match.\n"
"Subject2: continuation of the above line")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")