# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?(?=.*?^\h*param\h*=\N*).*?\K^\h*param\h*=\N*|.*?\K^\h*#+\h*param\h*=\N*)/${2}7/sm;t' <<< " ### param = 1
# param = 2
# param = 3
param = 4
# param = 5
"