#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\$([0-9\.\,]+).+$"
Local $sString = "$12.69/CS" & @CRLF & _
"$10000.69/CS" & @CRLF & _
"$10,000/CLAJ" & @CRLF & _
"$10,000.99/CA" & @CRLF & _
"$10,000,000,000,000.00/Cadflaj"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)