package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\$([0-9\.\,]+).+$`)
var str = `$12.69/CS
$10000.69/CS
$10,000/CLAJ
$10,000.99/CA
$10,000,000,000,000.00/Cadflaj`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}