const regex = /^(?:(?:Tel|Phone Number|Phone): )?(\+?\(?\d{3}\)?[-. ]\d{3}[-. ]\d{4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:Tel|Phone Number|Phone): )?(\\+?\\(?\\d{3}\\)?[-. ]\\d{3}[-. ]\\d{4})$', 'gm')
const str = `+111-111-1111
Tel: 111-111-1111
Phone Number: (111)-111-1111
Fax: 111-111-1111
Phone: 111-111-1111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}