$re = '/^[A-Z0-9\._\-\/]{1,15}(,[A-Z0-9\._\-\/]{1,15})*$/m';
$str = 'ABC,POPO1/1.2C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);