Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^[a-zA-Z0-9]+((_|-|\.)?[a-zA-Z0-9])*$
/
gm
Input 1
1
New
john john. john.doe john80 john_doe john__doe TESTUSER_john_doe _john john_doe_ john doe