re = /^[a-zA-Z0-9]+((_|-|\.)?[a-zA-Z0-9])*$/m
str = 'john
john.
john.doe
john80
john_doe
john__doe
TESTUSER_john_doe
_john
john_doe_
john doe
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end