use strict;
my $str = '123 - foo - asdf
234 - bar - abcdefg
345 - foobar and hello world';
my $regex = qr/^([^-]*?)\s*-\s*/mp;
my $subst = '$1, \'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";