// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^-]*?)\s*-\s*").unwrap();
let string = "123 - foo - asdf
234 - bar - abcdefg
345 - foobar and hello world";
let substitution = "$1, '";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}