$re = '/^(?=.*[~!@#$%^&*()_+`\-=\[\]\{\};\':\",./<>?])(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])\S{6,}$/m';
$str = 'abcdef
ABCDEFG
123456
!@#$%^
abc123
Abc123
adfasdf Abc123! dafdsfsf
Abc123\'
Abc$123
Abc 123
Aaaa$12
aaaA$12
$12aaaA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);