# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.*[~!@#$%^&*()_+`\-=\[\]\{\};':\",./<>?])(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])\S{6,}$"
test_str = ("abcdef\n"
"ABCDEFG\n"
"123456\n"
"!@#$%^\n"
"abc123\n"
"Abc123\n"
"adfasdf Abc123! dafdsfsf\n"
"Abc123'\n"
"Abc$123\n"
"Abc 123\n"
"Aaaa$12\n"
"aaaA$12\n"
"$12aaaA")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.