$re = '/\.?localhost$/mi';
$str = 'localhost
localhost.com
test.localhost
bleh.bleh1.localhost
3localhost
localhosting';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);