#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:^|[^\\\n])(?:\\{2})*)\{([#$&])([\w.]+)(?::([^}\\]*(?:\\.[^}\\]*)*))?}"
Local $sString = "{&var} --> Variable stored in a dictionary --> dict("var")" & @CRLF & _
"{$prop} --> Property of a class cls.prop read by CallByName and PropGet" & @CRLF & _
"{#const} --> Some constant values by name from a function" & @CRLF & _
"Value of foo is '{&var:DD.MM.YYYY}' and bar is '{$prop}'" & @CRLF & _
"Value of foo is '{&var:DD.{MM}.YYYY}' and bar is '{$prop}'" & @CRLF & _
"Value of foo is '{&var:DD.\{MM\}.YYYY}' and bar is '{$prop}'" & @CRLF & _
"This should not match '\{&var:DD.\{MM\}.YYYY\}' but this one '{&var:DD.\{MM\}.YYYY}'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")