#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(房间|卫生)*(收拾|清洁|打扫|清理|整理|换枕头|换床单)(房间|卫生|一下)*(垃圾)*"
Local $sString = "早餐" & @CRLF & _
"喂" & @CRLF & _
"嗯,不是,嗯,我我我不,我这边是去要五啊,我听同事说是应该有有水的桶装水吗" & @CRLF & _
"嗯,喂,你好,我问一下这个矿泉水有没有啊" & @CRLF & _
"嗯,请帮我把早餐送到房间来" & @CRLF & _
"嗯,我要两只矿泉水" & @CRLF & _
"二幺幺零需要开房间门" & @CRLF & _
"喂,你好,那个二幺幺零刚才出来取才能石门锁上了,让人把开吧" & @CRLF & _
"啊,我我说早餐不是,是上来吗" & @CRLF & _
"喂喂" & @CRLF & _
"嗯,我说话房间" & @CRLF & _
"我要换个房间" & @CRLF & _
"帮我送两瓶矿泉水过来" & @CRLF & _
"哎,你好,我这边需要早餐" & @CRLF & _
"喂,你好" & @CRLF & _
"嗯,我这边需要早餐" & @CRLF & _
"那是你们有起伏这个东西的" & @CRLF & _
"是这样,那个呃,我明天早上来早餐,你帮我之前说是九点钟送你帮我打了十点可以吗" & @CRLF & _
"我要订早餐" & @CRLF & _
"那个幺七零八的外卖送了吗" & @CRLF & _
"发胶" & @CRLF & _
"嗯,你们这有发胶吗" & @CRLF & _
"好久" & @CRLF & _
"喂,嗯,我哪个剃须刀过来" & @CRLF & _
"打电话什么是" & @CRLF & _
"哎,一个" & @CRLF & _
"那个送点的,送的那个牙刷牙膏上来楼" & @CRLF & _
"喂?喂" & @CRLF & _
"嗯,我我想那个幺五零九,我想送两份早餐" & @CRLF & _
"嗯,帮我点个餐" & @CRLF & _
"请帮我送两瓶矿泉水" & @CRLF & _
"啊点餐" & @CRLF & _
"也抽纸已经用完了送两包抽纸" & @CRLF & _
"你好,请给四要二房送,送两包抽纸两瓶水,谢谢" & @CRLF & _
"用完了" & @CRLF & _
"那个最迟什么时间退房啊" & @CRLF & _
"啊,你好,那个房间里边那个洗手池的那个水很小" & @CRLF & _
"帮我送件成人,寓意" & @CRLF & _
"成人浴衣,就是那个睡衣" & @CRLF & _
"我说苹果充电线,没有啦" & @CRLF & _
"我问一下啊,首先的我想要一个苹果的充电器" & @CRLF & _
"苹果的" & @CRLF & _
"那个充电线过来就可以了啊" & @CRLF & _
"一个枕头" & @CRLF & _
"一个水杯" & @CRLF & _
"全名侍者" & @CRLF & _
"菊花" & @CRLF & _
"针线包一个" & @CRLF & _
"哎,你好,我问一下这边是几点退房" & @CRLF & _
"我和钱财" & @CRLF & _
"啊,你们七点五这没有纸巾了,能复原吗" & @CRLF & _
"房间的网络是不是有问题" & @CRLF & _
"房间的网络是不是有问题啊" & @CRLF & _
"嗯,你好,那个苹果充电线可以快点拿过来吗,谢谢" & @CRLF & _
"香皂" & @CRLF & _
"你好,我想订下明天早餐" & @CRLF & _
"嗯" & @CRLF & _
"嗯,早餐可提供吗?早餐" & @CRLF & _
"嗯,暂时不需要,谢谢" & @CRLF & _
"我想问一下那个空" & @CRLF & _
"唉,那个早餐不是送上来吗" & @CRLF & _
"WiFi" & @CRLF & _
"嗯,我需要餐巾纸" & @CRLF & _
"我要变化早餐" & @CRLF & _
"电话线早餐" & @CRLF & _
"唉,你好,唉,要八幺零帮我送两瓶水,好吧" & @CRLF & _
"能帮我送两瓶矿泉水来吗" & @CRLF & _
"你好,请问你那边有尺子吗" & @CRLF & _
"啊,你是人工还是智能语音" & @CRLF & _
"嗯,你好,我想点个餐点一个台湾卤肉泛套餐" & @CRLF & _
"退房" & @CRLF & _
"酒店提供免费矿泉水吗" & @CRLF & _
"早餐吗" & @CRLF & _
"我需要一个手提袋,还有一双筷子" & @CRLF & _
"帮我拿那个两条苹果的数据线过来" & @CRLF & _
"没有快点" & @CRLF & _
"两瓶" & @CRLF & _
"嗯,我想问一下,现在可是没有瓶装水供应的是吧" & @CRLF & _
"帮我" & @CRLF & _
"要一把咖啡" & @CRLF & _
"剃须刀" & @CRLF & _
"嗯,帮我幺八零八拿一个" & @CRLF & _
"唉,你那个帮我拿两个那个浴袍上来" & @CRLF & _
"酒店提供咖啡吗" & @CRLF & _
"唉喂" & @CRLF & _
"不是说在从为啥我什么这个我只用完了都不再提供一点" & @CRLF & _
"我你,我请问下能服务那个幺七零六房间提供一些纸巾" & @CRLF & _
"嗯,WiFi怎么连接啊" & @CRLF & _
"什么" & @CRLF & _
"我想问一下是不会弄错,房间了,我订的是豪华大床双床房,这反这么小不限啊" & @CRLF & _
"卫生在" & @CRLF & _
"卫生袋" & @CRLF & _
"我要一个袋子" & @CRLF & _
"给送点餐巾纸,垃圾袋" & @CRLF & _
"送点,餐巾纸过来" & @CRLF & _
"呃,空调不制冷" & @CRLF & _
"哎,我这要要早餐,你快一点" & @CRLF & _
"我也没有,嗯" & @CRLF & _
"我要早餐幺五幺五零八房间" & @CRLF & _
"我这个早上怎么还没送过来啊" & @CRLF & _
"送两瓶水" & @CRLF & _
"好O" & @CRLF & _
"告诉我WiFi密码" & @CRLF & _
"那个我想问一下,我这插座没电" & @CRLF & _
"嗯,再送一个充电器" & @CRLF & _
"我一条浴巾" & @CRLF & _
"苹果充电线" & @CRLF & _
"送两双拖鞋" & @CRLF & _
"充电器吗" & @CRLF & _
"呃,你送一根华为的,送一根安卓的吧,嗯" & @CRLF & _
"安卓的" & @CRLF & _
"有的送两瓶水上的" & @CRLF & _
"啊,你好,那个二零零二帮我送两支矿泉水上来好吗?二零零二" & @CRLF & _
"我们唉我们打前台是多少" & @CRLF & _
"不是那个房七零五没有纸巾了,能送的纸巾吗" & @CRLF & _
"卫生纸" & @CRLF & _
"啊,送点纸成" & @CRLF & _
"直接" & @CRLF & _
"喂wife密码" & @CRLF & _
"送餐" & @CRLF & _
"平台" & @CRLF & _
"帮我拿个充电器上来苹果的" & @CRLF & _
"你就让他送就行" & @CRLF & _
"我房间需要饮用水" & @CRLF & _
"我要幺零七房间没有水" & @CRLF & _
"我要我要早餐,你这不是钱的吗" & @CRLF & _
"我要找她" & @CRLF & _
"额,我要早餐" & @CRLF & _
"送两瓶,瓶装水" & @CRLF & _
"请问一下WiFi密码" & @CRLF & _
"垃圾袋" & @CRLF & _
"你电话" & @CRLF & _
"嗯,验证吗?它是wife名字什么" & @CRLF & _
"这个wife多少" & @CRLF & _
"你好,呃房间的wifi连不上" & @CRLF & _
"你,我想改一下明天早上送早餐的时间" & @CRLF & _
"改一下,明天早上送餐的时间" & @CRLF & _
"嗯,送早餐" & @CRLF & _
"你好,我想问一下这个电视怎么能调试网络电视了" & @CRLF & _
"你要帮我送个红酒红酒开瓶器" & @CRLF & _
"嗯,帮我送一件年历比较墙的胶布到二三幺二" & @CRLF & _
"帮我送一点年历比较墙的胶布到二三幺二" & @CRLF & _
"有没动静啊" & @CRLF & _
"请用话筒说出你的啥呀" & @CRLF & _
"我要两个决明子枕" & @CRLF & _
"薰衣草枕" & @CRLF & _
"这两个薰衣草枕" & @CRLF & _
"安卓充电线" & @CRLF & _
"帮我拿条充电线上来在二零幺八" & @CRLF & _
"无线密码" & @CRLF & _
"额,我需一瓶水" & @CRLF & _
"七点" & @CRLF & _
"我想订下明天早餐" & @CRLF & _
"喂,我们是早餐送过来了,没有" & @CRLF & _
"酒店有矿泉水吗" & @CRLF & _
"嗯,你好,我那个餐室幺五幺七房后的,然后里面有两根冰激凌很久没有送上来,我怕掉了" & @CRLF & _
"对" & @CRLF & _
"开不房间" & @CRLF & _
"打扫房间" & @CRLF & _
"哎,你好,我记得不是说早餐送到房间来么" & @CRLF & _
"嗯,我是不是外卖到了,是你帮我送上来" & @CRLF & _
"我都外卖是不是已经在前台那里了,你是不是帮我送上来" & @CRLF & _
"两三个吧" & @CRLF & _
"八零五需要垃圾袋" & @CRLF & _
"那个八零五换一下垃圾箱,好吗" & @CRLF & _
"额,需要" & @CRLF & _
"洗衣机" & @CRLF & _
"现在" & @CRLF & _
"早餐在几楼" & @CRLF & _
"早餐在哪里吃" & @CRLF & _
"尽快送两瓶工装瓶装水" & @CRLF & _
"要两瓶水瓶装水" & @CRLF & _
"唉,请问是大厅吗" & @CRLF & _
"给我送两瓶水" & @CRLF & _
"一酒店的地址" & @CRLF & _
"请问咱们这个酒店的通讯地址是什么" & @CRLF & _
"啊,就是你们下面有有那个安卓的充电器啊" & @CRLF & _
"额,你这里无线那个有一个吗,就是不用密码的这个一个无线啊" & @CRLF & _
"我借一下餐盘" & @CRLF & _
"无线网" & @CRLF & _
"嗯,地板要西城" & @CRLF & _
"就是把床单被套整套换了最后在在要西城地板机场" & @CRLF & _
"我转前台,我要换床单,二四幺六" & @CRLF & _
"嗯,环保袋" & @CRLF & _
"我要刮胡刀" & @CRLF & _
"拿多一个袋子" & @CRLF & _
"袋子" & @CRLF & _
"不要了" & @CRLF & _
"两包制止没" & @CRLF & _
"咖啡" & @CRLF & _
"我要两杯咖啡,我要两包咖啡两包自己漠河一包" & @CRLF & _
"还要两包咖啡糖" & @CRLF & _
"哎,帮忙叫一下那个打扫房间" & @CRLF & _
"两个" & @CRLF & _
"唉,这哪个房间啊" & @CRLF & _
"送牙刷" & @CRLF & _
"帮我拿两件浴袍" & @CRLF & _
"快一点" & @CRLF & _
"给我拿个地区拿过来啊,那么久还没过来" & @CRLF & _
"我要两个荞麦枕和一个指甲钱" & @CRLF & _
"指甲钳" & @CRLF & _
"唉喂,你好,帮我送个早餐过来" & @CRLF & _
"你好,我需要洗那个牙刷" & @CRLF & _
"牙刷" & @CRLF & _
"你好,我想订一下,明天的早餐" & @CRLF & _
"转接到按楼层厅" & @CRLF & _
"哎,你好,那个我刚到这个房间是七二零,我看这个靠路边有点吵,能不能我也没进去,就是没没动的房间,我想一个那边西边的房间" & @CRLF & _
"我想换房间" & @CRLF & _
"我要换房间" & @CRLF & _
"帮我拿两个牙具和颐和一个梳子" & @CRLF & _
"嗯,帮我送一下早餐" & @CRLF & _
"嗯,可以了啊,就是苹果的手机充电线,充电出现" & @CRLF & _
"请帮忙送一个苹果手机的充电器" & @CRLF & _
"喂喂,请问WiFi密码是多少" & @CRLF & _
"餐巾纸,用完了" & @CRLF & _
"嗯,那个帮忙早餐送一下" & @CRLF & _
"喂,你好,这边最晚几点退房" & @CRLF & _
"不要送两瓶水,今天两瓶水,没送" & @CRLF & _
"再送两瓶" & @CRLF & _
"是的" & @CRLF & _
"送四瓶水" & @CRLF & _
"帮我取个刮胡刀,谢谢" & @CRLF & _
"你" & @CRLF & _
"嗯,这哪个酒店啊" & @CRLF & _
"那个我们要八零幺的那个早餐能不能早点送过来啊" & @CRLF & _
"你好,我有那个外卖在前台,你帮我送上来" & @CRLF & _
"嗯,请问有苹果充电线吗"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")