import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<dependency>\\s+<groupId>)(.+)(</groupId>\\s+<artifactId>)(.+)(</artifactId>\\s+<version>)([^\\$]+?)(</version>[\\s\\S]*?\\s+</dependency>)";
final String string = " <dependency>\n"
+ " <groupId>org.example.one</groupId>\n"
+ " <artifactId>example1</artifactId>\n"
+ " <version>1.2.3</version>\n"
+ " </dependency>\n"
+ " <dependency>\n"
+ " <groupId>org.example.two</groupId>\n"
+ " <artifactId>example2</artifactId>\n"
+ " <version>${example2.version}</version>\n"
+ " </dependency>\n"
+ " <dependency>\n"
+ " <groupId>org.example.three</groupId>\n"
+ " <artifactId>example3</artifactId>\n"
+ " <version>1.2.3</version>\n"
+ " <scope>test</scope>\n"
+ " </dependency>\n"
+ " <dependency>\n"
+ " <groupId>org.example.four</groupId>\n"
+ " <artifactId>example4</artifactId>\n"
+ " <version>${example4.version}</version>\n"
+ " <scope>test</scope>\n"
+ " </dependency>\n"
+ " <dependency>\n"
+ " <groupId>org.example.five</groupId>\n"
+ " <artifactId>example5</artifactId>\n"
+ " <version>1.2.3</version>\n"
+ " <scope>test</scope>\n"
+ " <exclusions>\n"
+ " <exclusion>\n"
+ " <artifactId>*</artifactId>\n"
+ " <groupId>*</groupId>\n"
+ " </exclusion>\n"
+ " </exclusions>\n"
+ " </dependency>\n"
+ " <dependency>\n"
+ " <groupId>org.example.six</groupId>\n"
+ " <artifactId>example6</artifactId>\n"
+ " <version>${example6.version}</version>\n"
+ " <scope>test</scope>\n"
+ " <exclusions>\n"
+ " <exclusion>\n"
+ " <artifactId>*</artifactId>\n"
+ " <groupId>*</groupId>\n"
+ " </exclusion>\n"
+ " </exclusions>\n"
+ " </dependency>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}