package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\w]|\b\w{1,2}\b)`)
var str = `this is a test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}