package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[+\-]?(\d+\.\d*|\d*\.\d+|\d+)([eE][+\-]?\d+)?`)
var str = `2
0089
-0.1
+3.14
4.
-.9
2e10
-90E3
3e+7
+6e-1
53.5e93
-123.456e789
abc
1a
1e
e3
99e2.5
--6
-+3
95a54e53`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}