const regex = /.*?(?:Keywords:?\s)(.*?,.*?,.*?(?<!,)(?=\s[A-Z])){1,2}.*?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?(?:Keywords:?\\s)(.*?,.*?,.*?(?<!,)(?=\\s[A-Z])){1,2}.*?$', 'gm')
const str = `This is a random text Keywords AA, bB, CC Hi stack overflow
Hi stackoverflow Keywords: a, b, Stack Overflow Some more text`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);