Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
\[(?P<key>.+?)(?:\s+(?P<settings>.*?))?\]
"
gmsu
Test String
New
### The I_Soil System The I-soil material model is a nonlinear hysteretic soil model that is based on the distributed element models developed by [!citet](iwan1967on) and [!citet](chiang1994anew). In 1-D, this model takes the backbone stress-strain curve and divides it into a set of elastic-perfectly plastic curves. The total stress then is the sum of the stresses from the individual elastic-perfectly plastic curves. The three dimensional generalization of this model is achieved using von-Mises failure criteria for each elastic-perfectly plastic curve resulting in an invariant yield surfaces in three-dimensional stress space like in [fig:yieldsurface] (after [!citet](chiang1994anew)).