use strict;
my $str = 'This is a baaaad unnnnecessary short word';
my $regex = qr/\s*\p{L}*(\p{L})\1{2}\p{L}*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";