$re = '/\s*\p{L}*(\p{L})\1{2}\p{L}*/m';
$str = 'This is a baaaad unnnnecessary short word';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;