re = /\s*\p{L}*(\p{L})\1{2}\p{L}*/m
str = 'This is a baaaad unnnnecessary short word'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result