import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<body.*?>(.*?)<\\/body>";
final String string = "7687687toyi7fy\n"
+ "<body style=\"box-sizing: border-box; height: inherit; width: inherit; \n"
+ "margin: 0px; overflow: hidden\">\n"
+ "lkjlknkjyyugtfiytfif\n"
+ "</body>\n"
+ "</html>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}