// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)<body.*?>(.*?)<\/body>").unwrap();
let string = "7687687toyi7fy
<body style=\"box-sizing: border-box; height: inherit; width: inherit;
margin: 0px; overflow: hidden\">
lkjlknkjyyugtfiytfif
</body>
</html>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}