use strict;
my $str = 'Focal Point (BUGS BUNNY; bugs.bunny@looonytune.car; 888-555-1111)\\nCartoon Car (DAFFY DUCK; daffyduck@disney.com; 888-555-1112)\\nCartoon Car (243; daffyduck@disney.com; 888-555-1113)';
my $regex = qr/(?<=Cartoon Car \()[a-z]+(?: +[a-z]*);[^;]+(?=.*;)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}